News

Interoperability to Logic Pro X 10.6 and Cubase 11

We have tested A.O.M. Audio Plugins 1.10.3 with Logic Pro X 10.6 and Cubase 11. No interoperability problem was found so far. Please contact to helpdesk when you find any problems.